Главная страница


ru.cisco

 
 - RU.CISCO ---------------------------------------------------------------------
 From : Alexey Vissarionov                   2:5020/545     27 Feb 2008  18:24:42
 To : All
 Subject : 6504 + VRF
 -------------------------------------------------------------------------------- 
 
 
 Есть вот такая хитромудрая конструкция:
 
             DMZ
 7201 --+     |
        +--- 6504 ---- 7206 --- внешний мир
 7201 --+     |
  |          eth
  |           |
  +- pppoe -[USER]
 Hа 7201 посредством PPPoE цепляются усеры (случайно на любую из нескольких,
 посему между 7201, 6504 и 7206 поднят OSPF). Те же усеры соединены между собой
 локальной сетью, маршрутизируемой посредством 6504.
 
 Дабы разграничить PPPoE и локалку, первый засунут в VRF:
 
 ip vrf pppoe
  rd 400:1
  route-target export 400:1
  route-target import 400:1
 
 interface Vlan601
  ip vrf forwarding pppoe
  ip address 192.168.200.9 255.255.255.248
 
 interface Vlan602
  ip vrf forwarding pppoe
  ip address 192.168.15.1 255.255.255.248
  ip policy route-map vrf_route
 
 interface Vlan603
  ip vrf forwarding pppoe
  ip address 192.168.16.1 255.255.255.248
 
 interface Vlan604
  ip vrf forwarding pppoe
  ip address 192.168.14.1 255.255.255.248
  ip policy route-map vrf_route
  ip ospf network non-broadcast
 
 router ospf 1 vrf pppoe
  log-adjacency-changes
  capability vrf-lite
  area 1 nssa no-redistribution no-summary
  area 3 nssa no-redistribution no-summary
  summary-address 192.168.0.0 255.255.0.0 tag 555
  summary-address 10.0.0.0 255.0.0.0 tag 555
  network 192.168.14.0 0.0.0.7 area 3
  network 192.168.15.0 0.0.0.7 area 1
  network 192.168.16.0 0.0.0.7 area 0
  neighbor 192.168.14.2
 
 route-map vrf_route permit 10
  match ip address 160
  set ip next-hop 192.168.200.11
 
 route-map vrf_route permit 20
  match ip address 170
  set ip next-hop 192.168.16.2
 
 route-map vrf_route permit 30
  match ip address 180
  set ip next-hop 192.168.200.10
 
 Все работает, но при этом загрузка процессора на 6504 колеблется в районе
 40...50% (до включения VRF было не более 10%). Известно, что "PFC does not
 provide hardware support for PBR configured with the set ip next-hop keywords if
 the next hop is a tunnel interface" - но, насколько я понимаю, VRF не является
 тоннелем.
 
 Да, чуть не забыл `sh ver`:
 
 Cisco IOS Software, s72033_rp Software (s72033_rp-ADVIPSERVICESK9_WAN-M),
 Version 12.2(33)SXH, RELEASE SOFTWARE (fc5)
 Technical Support: http://www.cisco.com/techsupport
 Copyright (c) 1986-2007 by Cisco Systems, Inc.
 Compiled Sun 19-Aug-07 07:38 by prod_rel_team
 
 Собственно, вопрос: где я дурак?
 --
 Alexey V. Vissarionov aka Gremlin from Kremlin
 gremlin ПРИ gremlin ТЧК ru; +vii-cmiii-ccxxix-lxxix-xlii
 
 ... Профессионализм - умение оценить меру своей некомпетентности
 --- /bin/vi
  * Origin: http://openwall.com/Owl/ru/ (2:5020/545)
 
 

Вернуться к списку тем, сортированных по: возрастание даты  уменьшение даты  тема  автор 

 Тема:    Автор:    Дата:  
 6504 + VRF   Alexey Vissarionov   27 Feb 2008 18:24:42 
Архивное /ru.cisco/229447c573d3.html, оценка 3 из 5, голосов 10
Яндекс.Метрика
Valid HTML 4.01 Transitional